Pale Moon 29.2.0 støtter ikke eldre Firefox -utvidelser lenger som ikke er portet

Da Mozilla byttet fra sitt eldre tilleggssystem til WebExtensions, så Firefox gafler som Pale Moon en økning i brukere som ønsket å fortsette å bruke utvidelser som Mozillas nye system ikke lenger støttet. Ikke alle utvidelser fungerte, men mange gjorde det, og brukerne kunne fortsette å bruke disse utvidelsene.

Utgivelsen av Pale Moon 29.2.0 endrer nettleserens utvidelseskompatibilitet på en viktig måte, ettersom den fjerner støtte for eldre Firefox -utvidelser som ikke er justert for å fungere med Pale Moon -nettleseren. Omtrent 230 utvidelser er for tiden tilgjengelige for Pale Moon on the offisielt nettsted for Pale Moon-tillegg , inkludert populære utvidelser som Decentraleyes, uBlock Origin (Legacy) eller FoxyProxy.

I henhold til et foruminnlegg av Moonchild, Pale Moon -prosjekteeier, ble støtte for Firefox -utvidelser alltid ansett som midlertidig av utviklingsteamet. Klassiske Firefox -utvidelser installeres kanskje ikke i det hele tatt i Pale Moon eller kan føre til kompatibilitetsproblemer, og det er en av hovedårsakene til å blokkere klassiske Firefox -utvidelser i Pale Moon 29.2.0.

pale moon 29.2.0 addon -kompatibilitet

Utvidelser som ikke er kompatible, kan portes for å gjøre dem kompatible med Pale Moon -nettleseren, men hvem skal gjøre det? For prosjektgruppen Pale Moon er svaret klart. Det er fellesskapet som må øke for å sikre at utvidelser de bruker, er kompatible med nettleseren. Realistisk sett vet de fleste nettleserbrukere ikke hvordan de skal lage nettleserutvidelser eller endre dem for å få dem til å fungere. Pale Moon -teamet kan heller ikke portere flertallet av nettleserutvidelser til nettleseren, noe som etterlater en liten gruppe medlemmer av samfunnet med ferdigheter og tid til å overføre noen av utvidelsene til nettleseren.

En tråd er tilgjengelig på det offisielle Pale Moon -forumet for legg ut kritiske utvidelser som bare er Firefox .

Pale Moon -brukere kan forbli på versjon 29.1.1 av nettleseren som et midlertidig tiltak for å fortsette å bruke utvidelser som ellers ville blitt deaktivert i Pale Moon 29.2.0 eller nyere. Et godt alternativ for å teste kompatibilitet er å bruke en bærbar kopi av Pale Moon 29.2.0 og teste utvidelseskompatibilitet i den versjonen for å se hvilke av de installerte utvidelsene som forblir kompatible og hvilke som ikke gjør det. Nedgradering til en tidligere versjon av Pale Moon etter installasjon av 29.2.0 -oppgraderingen anbefales ikke, da det kan føre til problemer med profilkompatibilitet.

Pale Moon 29.2.0 ble utgitt 27. april 2021 .

Nå du : bruker du Pale Moon? Blir du påvirket av kompatibilitetsendringen?